Gönderen Konu: Amiga 500 Grafik Sorunu (Videolu) (ÇÖZÜLDÜ)  (Okunma sayısı 4177 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı 68k

  • Retro Meraklısı
  • ***
  • İleti: 247
Ynt: Amiga 500 Grafik Sorunu (Videolu)
« Yanıtla #15 : 13 Haziran 2020, 23:40:29 »
Bu da sıcak hava tabancasının maker versiyonu


Güzel yapmış da pili nerde şarj edecek? Bende büyük ısı tabancası var ama nozul lazım bu arada, çok geniş alana üflüyor böylece sökmek istemediğim komponentler de sökülüyor...

Çevrimdışı 68k

  • Retro Meraklısı
  • ***
  • İleti: 247
Ynt: Amiga 500 Grafik Sorunu (Videolu)
« Yanıtla #16 : 16 Haziran 2020, 13:52:53 »
Bir arkadaştan temin ettiğim çipset ulaştı ve tek tek denedim ama çare olmadı.  :-\

Çevrimdışı Ref

  • Yönetici
  • Özgür Retrocu
  • *
  • İleti: 2653
  • Advanced User Simulator
    • ae unutmadan
Ynt: Amiga 500 Grafik Sorunu (Videolu)
« Yanıtla #17 : 16 Haziran 2020, 14:41:23 »
Bir arkadaştan temin ettiğim çipset ulaştı ve tek tek denedim ama çare olmadı.  :-\

çipsetten kasıt ne? tüm custom çipler mi? yoksa denise mü?

Çevrimdışı 68k

  • Retro Meraklısı
  • ***
  • İleti: 247
Ynt: Amiga 500 Grafik Sorunu (Videolu)
« Yanıtla #18 : 16 Haziran 2020, 14:53:43 »
Bir arkadaştan temin ettiğim çipset ulaştı ve tek tek denedim ama çare olmadı.  :-\

çipsetten kasıt ne? tüm custom çipler mi? yoksa denise mü?

Hepsi. Agnus, Gary, Denise, CIA'ler, Paula, 68k, ROM. Bu arada MegaTest disketindeki Sprite Test saçmalıyor. Bu sprite test nereye abanıyor olabilir?

Çevrimdışı Ref

  • Yönetici
  • Özgür Retrocu
  • *
  • İleti: 2653
  • Advanced User Simulator
    • ae unutmadan
Ynt: Amiga 500 Grafik Sorunu (Videolu)
« Yanıtla #19 : 16 Haziran 2020, 15:32:58 »
Alıntı
Sendeki bu havya mı:
evet, bu havya ben de burdan almıştım hatta. ama yedek uç al, şu tornavida gibi olan TS-D24 model. edit: uyarı, bir de kaliteli laptop PSU'su lazım yüksek amperli 19V olanlardan.



Bir arkadaştan temin ettiğim çipset ulaştı ve tek tek denedim ama çare olmadı.  :-\

çipsetten kasıt ne? tüm custom çipler mi? yoksa denise mü?

Hepsi. Agnus, Gary, Denise, CIA'ler, Paula, 68k, ROM. Bu arada MegaTest disketindeki Sprite Test saçmalıyor. Bu sprite test nereye abanıyor olabilir?

amiganın ekran kartı denise'dır. tüm grafik işlemleri o halleder.  Yukarıdaki görüntü bana direkt olarak denise girdi/çıktısındaki problem gibi görünüyor.

Tabii amiga demek agnus demek, denise'e tüm veriyi yükleyen agnustur, ramdan veriyi çeker, blitter, copper gibi operasyonları da hallettikten sonra veriyi denise'e uzatır. bu veriyi yorumlayarak görüntüyü oluşturan denise'dür. Sprite test denise'e abanır.

hem agnus hem denise'i değiştirdin ve iyileşme olmadıysa o zaman aklıma aradaki bufferlarda sorun olabileceği geliyor.

bu da denise'in specleri, dikkat edersen 16 pin agnustan geliyor, çıkışta 74LS245'lerle RGB karıştırılıyor, osiloskopun olsa onları da kontrol et derdim.

https://www.amigawiki.org/lib/exe/fetch.php?media=de:parts:denise_specs.pdf

Son olarak sanırım bu senin amiganın diyagramı:
https://www.amigawiki.org/dnl/schematics/A500_R6.pdf
tipine bakarak Rev 6a olduğunu tahmin ettim ama ciddi fark olmaması gerek

Çevrimdışı Alcofribas

  • Yönetici
  • Özgür Retrocu
  • *
  • İleti: 1902
  • "Kahraman olmak, dürüst olmaktan kolaydır" Luigi P
    • Sizin Amstrad
Ynt: Amiga 500 Grafik Sorunu (Videolu)
« Yanıtla #20 : 16 Haziran 2020, 19:04:23 »
Birkaç sorum var:

1-) Capsleri değiştirdin mi? Emici havya geldi mi?

2-) Noktalar aynı oyunu/programı her yüklediğinde aynı yerde mi çıkıyor? Elbette hepsini kontrol edemezsin ama belli bir bölgeyi kendine test için referans alabilirsin.

3-) Farklı bir oyun/program yüklediğinde noktalar farklı yerde mi yoksa konumlarını koruyorlar mı? Elbette yine daraltılmış bir alanı referans alarak.

4-) Noktalarda renk nasıl? Hepsi misal beyaz gibi aynı renk mi yoksa değişebiliyor mu? Her yüklemede renk değişimi var mı?

5-) Power olarak ne kullanıyorsun? Bunu değiştirip yukarıda yazdıklarımı gözlemleme şansın var mı?

6-) Monochrome çıkıştan görüntü alıp gözlemledin mi?

7-) Cihazı ilk aldığında içi temiz miydi? Sen herhangi bir temizlik işlemi yaptın mı?

Çevrimdışı 68k

  • Retro Meraklısı
  • ***
  • İleti: 247
Ynt: Amiga 500 Grafik Sorunu (Videolu)
« Yanıtla #21 : 16 Haziran 2020, 19:25:34 »
Alıntı
evet, bu havya ben de burdan almıştım hatta. ama yedek uç al, şu tornavida gibi olan TS-D24 model. edit: uyarı, bir de kaliteli laptop PSU'su lazım yüksek amperli 19V olanlardan.

Tamamdır, laptop PSU kolay, sağda solda yatan 3-5 tane var.

Alıntı
Tabii amiga demek agnus demek, denise'e tüm veriyi yükleyen agnustur, ramdan veriyi çeker, blitter, copper gibi operasyonları da hallettikten sonra veriyi denise'e uzatır. bu veriyi yorumlayarak görüntüyü oluşturan denise'dür. Sprite test denise'e abanır.
PC'deki GPU-RAMDAC ilişkisi gibi bir nevi yani? GPU math hesaplar da RAMDAC rasterize eder, kabaca bilgim böyle..

Alıntı
bu da denise'in specleri, dikkat edersen 16 pin agnustan geliyor, çıkışta 74LS245'lerle RGB karıştırılıyor, osiloskopun olsa onları da kontrol et derdim.
Osiloskopum yok maalesef ama DS-0138 diy oyuncağım var  ;D Bunlar piyasada bulunan logic entegrelerdir umarım, direkt değiştireyim bulabilirsem.

Alıntı
Son olarak sanırım bu senin amiganın diyagramı:

Evet sanırım 6A bendeki de. en sağda beyaz fontla HK-6A-03 yazıyor.

Çevrimdışı 68k

  • Retro Meraklısı
  • ***
  • İleti: 247
Ynt: Amiga 500 Grafik Sorunu (Videolu)
« Yanıtla #22 : 16 Haziran 2020, 19:38:59 »
Alıntı
1-) Capsleri değiştirdin mi? Emici havya geldi mi?

Hepsini değil, Denise, Agnus ve 68k civarında toplamda 6 tane değiştirdim. Emici havya geldi evet ama henüz girişemedim. Kalanları da komple değiştiririm bu arada.

Alıntı
2-) Noktalar aynı oyunu/programı her yüklediğinde aynı yerde mi çıkıyor? Elbette hepsini kontrol edemezsin ama belli bir bölgeyi kendine test için referans alabilirsin.

Lotus'ta birebir aynı yerde ve aynı renkler. Ancak bütün oyunlarda videosunu attığım Lotus'taki gibi artficatlar çıkıp makine restart atmıyor. Örneğin DynaBlaster menüler filan sorunsuz ama oyun başladığında görüntü gidip müzik devam ediyor. (Bu arada oyun 50Hz modlu, onda sorun yok çünkü 60Hz versiyonu monitörün desteklediği sync dışında kalmıştı. Onda menüleri, "cutscene"i filan da göremiyordum.) Restart yok. Arkanoid gibi bazı oyunlardaysa ekranın bazı bölgelerinde artifactlar olmasına rağmen oyun oynanmaya devam edilebiliyor. Son olarak PPHammer, Agony, Twintris, IK+ gibi oyunlardaysa hiçbir problem yok. [Ek: Benim mantığım diyor ki bu oyunların kullandığı mimari özellikler aslında troubleshooting için en iyi ipucu ama ben bu derecede Amiga mimarisi, ayrıca da tabii bu oyunların kullandığı trickleri bilmiyorum. Twintris nereyi kullanmıyor da Lotus orayı kullanıyorsa sorunun orada olduğu açık değil mi?]

Alıntı
3-) Farklı bir oyun/program yüklediğinde noktalar farklı yerde mi yoksa konumlarını koruyorlar mı? Elbette yine daraltılmış bir alanı referans alarak.
Farklı yerlerdeler. Bir önceki maddede anlatmaya çalıştığım gibi Arkanoid'in noktaları kendine has başka bir yerde, ama onunkiler de sabit. Her seferinde ordalar ve aynı renkteler.

Alıntı
4-) Noktalarda renk nasıl? Hepsi misal beyaz gibi aynı renk mi yoksa değişebiliyor mu? Her yüklemede renk değişimi var mı?
Her yüklemede renk değişimi yok. En belirgini Lotus'taki hali, parça pinçik pixellerin bir kısmı eksik ve eksik olmayanlar da olması gereken renkte değiller. Bu arada introyu beklemeyip görmeden menüleri geçersem Lotus'un oyun içinde yine problem yok.

Alıntı
5-) Power olarak ne kullanıyorsun? Bunu değiştirip yukarıda yazdıklarımı gözlemleme şansın var mı?
Power olarak gözden çıkardığım mini-itx noname bir PC psu kullanıyordum, az yer kaplasın diyerekten bunu kesip biçmiş ve square DIN lehimlemiştim. O dandikten FSP-60atv'ye geçtim, hiçbir değişim olmadı. Şu an yazdığım PC'deki Seasonic'i söküp deneyeyim diyeceğim de, FSP 60ATV'den sonra gerek var mı sizce?

Alıntı
6-) Monochrome çıkıştan görüntü alıp gözlemledin mi?
Evet aynı durum onda da var. Tabii renkleri göremiyorum ama pixellerin durumu, reset atma filan her şey yerli yerinde...

Alıntı
7-) Cihazı ilk aldığında içi temiz miydi? Sen herhangi bir temizlik işlemi yaptın mı?

Ben bu makineyi alalı en az 10 yıl olmuştur. İlk aldığımda bütün parçaları çöpten çıkmış gibiydi. (Kargoyla geldi.) Floppy'sini tutunca elimde dağıldı mesela, kasanın içinden toz, pas, pislik aktı ve sair. Genel durumu hiç iyi değildi. O gün anakart hariç parçaların hepsini atıp sadece anakartı ayırmıştım, onu da kıyamadım yoksa güç verilince çalışacağını hiç ummuyordum. Temizlik adına kabaca ne yaptımsa o gün yaptım. Diğer parçaları attıktan sonra anakartı direkt su veya bolca wd-40 ile yıkadığımı hatırlıyorum. O şekilde hiç elektrik vermeden yıllarca yattı, çalışmaz gözüyle bakıyordum, uğraşasım yoktu o yüzden. Bir gün dur şunla bir uğraşayım dedim ve elimde square din dahi olmadığı halde power sokete uygun metal pinler sokuşturarak güç verdiğimde ekrana görüntü geldiğinde hala çalıştığına inanamamıştım.  :D Sonra sağdan solda parça denk geldikçe toplamaya başladım, mouse birinden, klavye başka birinden, Gotek alix'ten, skart kendi eski 90'lardan kalma skart kablomdu, bitpazarından 2tl'ye aldığım ps1 padini şuna joystik yapayım filan derken bugün bu hale geldi. (Joystik çalışıyor  8))

İşte geçen hafta da kasayı alınca gene raftan indirip uğraşmaya başladım. Bu sorunu da yeni fark ettim çünkü bu kadar etraflıca kullanmamıştım. Ondan sonra biraz çiplerin soketleri, gözüme çarpan sağını solunu filan Loctite kontakt spray'le temizledim... biraz uzun oldu ama makinenin bendeki hikayesi böyle :)

Çevrimdışı 68k

  • Retro Meraklısı
  • ***
  • İleti: 247
Ynt: Amiga 500 Grafik Sorunu (Videolu)
« Yanıtla #23 : 17 Haziran 2020, 23:21:40 »
Sorun çözüldü: aslında sorun yokmuş  :o Buraya da üye olduğunu sandığım Eşref arkadaşımız aynı durumun UAE'de de yaşandığını fark etti. Benim UAE konfigürasyonum hep 1mb olduğundan ve böyle bir şeye ihtimal dahi vermediğimden (çocukluğumda RAM'siz Amiga'larda böyle bir sorun deneyimlememiştim) aklımın ucundan geçmeyeni düşünüp deneyerek sorunun bazı oyunlardaki RAM yetersizliğine bağlı olarak ortaya çıktığını keşfederek sorunu çözdü, bilmediğimiz bir şeyi daha öğrenmiş olduk. Emeği geçen herkese teşekkürler.

Çevrimdışı Ref

  • Yönetici
  • Özgür Retrocu
  • *
  • İleti: 2653
  • Advanced User Simulator
    • ae unutmadan
Ynt: Amiga 500 Grafik Sorunu (Videolu) (ÇÖZÜLDÜ)
« Yanıtla #24 : 17 Haziran 2020, 23:27:52 »
hahahah bu da süpriz son oldu resmen. hiç kimse de ihtimal vermedi 1MB olmadığına :D

Çevrimdışı 68k

  • Retro Meraklısı
  • ***
  • İleti: 247
Ynt: Amiga 500 Grafik Sorunu (Videolu) (ÇÖZÜLDÜ)
« Yanıtla #25 : 18 Haziran 2020, 00:13:04 »
İşte hayat, sen gel nickini 68k yap ama Amigan 512k olsun  ::) ;D

Çevrimdışı 68k

  • Retro Meraklısı
  • ***
  • İleti: 247
Ynt: Amiga 500 Grafik Sorunu (Videolu) (ÇÖZÜLDÜ)
« Yanıtla #26 : 18 Haziran 2020, 07:07:14 »
Bu arada Alcofribas'ın tavsiye ettiği ucuz model lehim emici havya fiyatına göre gayet iyi. Bunca zaman boşa çile çekmişim.

Çevrimdışı C64Esref

  • Retroman
  • ***
  • İleti: 32
    • portfolyo sitem
Ynt: Amiga 500 Grafik Sorunu (Videolu) (ÇÖZÜLDÜ)
« Yanıtla #27 : 18 Haziran 2020, 18:49:49 »
Güle güle kullanın :) Evet buradaki nickimde C64Esref. Sevgiler :)
AMIGA 500 | GOTEK | 1 MB RAM | 1.3 ROM
AMIGA 1200 | 8GB CF  | 3.1 ROM | 8 MB RAM | HDMI-520
COMMODORE 64 | IRQHack64 | KissCart64 | Pizero1541 | 64K CUPCAKE-CART | 1084 S

Çevrimdışı 68k

  • Retro Meraklısı
  • ***
  • İleti: 247
Ynt: Amiga 500 Grafik Sorunu (Videolu) (ÇÖZÜLDÜ)
« Yanıtla #28 : 18 Haziran 2020, 21:30:12 »
Güle güle kullanın :) Evet buradaki nickimde C64Esref. Sevgiler :)

Selam, çipseti en kısa sürede geri yolluyorum. Pazartesi gibi olabilir. Bir de buradan teşekkür edeyim :)

Ayrıca şurada söylediklerine göre Lotus'un cracksiz IDF formatında aynı sorun olmuyormuş. Biraz IDF - Gotek ilişkisini araştırayım çünkü IDF formatını hiç kullanmadım daha önce.

https://eab.abime.net/showthread.php?p=1408702#post1408702

Çevrimdışı C64Esref

  • Retroman
  • ***
  • İleti: 32
    • portfolyo sitem
Ynt: Amiga 500 Grafik Sorunu (Videolu) (ÇÖZÜLDÜ)
« Yanıtla #29 : 18 Haziran 2020, 21:55:54 »
Güle güle kullanın :) Evet buradaki nickimde C64Esref. Sevgiler :)

Selam, çipseti en kısa sürede geri yolluyorum. Pazartesi gibi olabilir. Bir de buradan teşekkür edeyim :)

Ayrıca şurada söylediklerine göre Lotus'un cracksiz IDF formatında aynı sorun olmuyormuş. Biraz IDF - Gotek ilişkisini araştırayım çünkü IDF formatını hiç kullanmadım daha önce.

https://eab.abime.net/showthread.php?p=1408702#post1408702
Rica ederim. Sorun tespit edildiğine göre geri gönderebilirsiniz. İsterseniz ram kart alıp testlere devam etmek isterseniz kalada bilir. Bir ram kart mutlaka edinin derim. Goteği de kendiniz yapabilirsiniz. Hazır pahalıya gelebilir.
AMIGA 500 | GOTEK | 1 MB RAM | 1.3 ROM
AMIGA 1200 | 8GB CF  | 3.1 ROM | 8 MB RAM | HDMI-520
COMMODORE 64 | IRQHack64 | KissCart64 | Pizero1541 | 64K CUPCAKE-CART | 1084 S